[collectd] Collectd on CentOS always broken?

O G otis_junk at yahoo.com
Mon Apr 23 18:17:28 CEST 2012

Hi Travis,
Thanks for replying!  I'm using this minimalistic collectd.conf:
 Hostname    "localhost"
FQDNLookup   true
BaseDir     "/opt/collectd/var/lib/collectd"
PIDFile     "/opt/collectd/var/run/collectd.pid"
PluginDir   "/opt/collectd/lib/collectd"
TypesDB     "/opt/collectd/share/collectd/types.db"
#Interval     10
#Timeout      2
#ReadThreads  5
LoadPlugin syslog
LoadPlugin logfile
<Plugin logfile>
        LogLevel info
        File "/tmp/collectd.log"
        Timestamp true
        PrintSeverity true
<Plugin syslog>
        LogLevel info
LoadPlugin cpu
I've now also compiled and installed collectd 5.1.0 by hand (configure, make, make install) on "Amazon Linux AMI" (something based on RedHat, it seems, since it has yum) and I got the exact same error message.  So I'm starting to suspect I'm doing something wrong with Collectd.
# /opt/collectd/sbin/collectd -help
Builtin defaults:
  Config file       /opt/collectd/etc/collectd.conf
  PID file          /opt/collectd/var/run/collectd.pid
  Plugin directory  /opt/collectd/lib/collectd
  Data directory    /opt/collectd/var/lib/collectd        <== nothing shows up here or in /opt/collectd/var/log/
collectd 5.1.0, http://collectd.org/
I've tried starting Collectd like this:
# /opt/collectd/sbin/collectd -C /opt/collectd/etc/collectd.conf
As well we like this:
# /opt/collectd/sbin/collectdmon -c /opt/collectd/etc/collectd.conf
Any help would be greatly appreciated.
----- Original Message -----
From: Travis Crowder <travis.crowder at spechal.com>
To: O G <otis_junk at yahoo.com>
Sent: Sunday, April 22, 2012 1:21 PM
Subject: Re: [collectd] Collectd on CentOS always broken?

On 4/21/2012 11:25 PM, O G wrote:
> Hello,
>   Is there a version of CentOS with a working Collectd?
> I have tried several CentOS 5.* and 6.* versions where I installed Collectd with yum install collectd and each of them had a non-working Collectd.
>   This is a common error message I'd find in /var/log/messages:
>   Filter subsystem: Built-in target `write': Dispatching value to all write plugins failed with status 2 (ENOENT). Most likely this means you didn't load any write plugins
>   Of course, there were plugins in collectd.conf that write stuff to filesytem.
>     Is there a version of CentOS with a working Collectd?
>   Thanks,
> Otis
> _______________________________________________
> collectd mailing list
> collectd at verplant.org
> http://mailman.verplant.org/listinfo/collectd

I use Collectd exclusively on CentOS servers; CentOS 5 and CentOS 6.  I install via YUM and build from source without issue.

Can you post your collectd.conf from /etc/ or /opt/collectd/etc ?


More information about the collectd mailing list