[collectd] couchdb plugin rename?

Doug MacEachern Doug.MacEachern at springsource.com
Thu Aug 20 19:31:22 CEST 2009

Wanted to bring this up before 4.8..
When I first started on the couchdb plugin, there were metrics  
specific to couchdb, but ended up making it generic and the metrics  
are all specified in the config.  Since then, I've looked at Dynomite  
which has its own set of metrics exposed the same way: http://gist.github.com/137771
Also noticed Hadoop 0.21 daemons now support: "/metrics?format=json to  
retrieve the data in a structured form.", but haven't had a chance to  
try yet.  I'm sure there's more too.  So I'm wondering if 'couchdb'  
should be renamed to something more generic, 'json' or 'yajl'  maybe?
And/or pushing the curl/yajl code out to util functions, then add the  
couchdb specific metrics to the couchdb plugin.  Then also use the  
util functions for dynomite, hadoop, etc., specific plugins.  Thoughts?

More information about the collectd mailing list