[collectd] couchdb plugin rename?
octo at verplant.org
Thu Aug 20 19:55:26 CEST 2009
On Thu, Aug 20, 2009 at 10:31:22AM -0700, Doug MacEachern wrote:
> Since then, I've looked at Dynomite which has its own set of metrics
> exposed the same way: http://gist.github.com/137771
> Also noticed Hadoop 0.21 daemons now support: "/metrics?format=json to
> retrieve the data in a structured form.", but haven't had a chance to
> try yet.
neat – one ring to rule them all! ;)
> So I'm wondering if 'couchdb' should be renamed to something more
> generic, 'json' or 'yajl' maybe?
Sounds reasonable. I think “curl_json” and “curl_yajl” would be good
> And/or pushing the curl/yajl code out to util functions, then add the
> couchdb specific metrics to the couchdb plugin. Then also use the
> util functions for dynomite, hadoop, etc., specific plugins.
I've thought about putting the libcurl stuff into an external module
today, too, when I was writing the “follow redirections” patch .
The yajl code could possibly be abstracted similar to the “match” code
In the future, we might be able to add other parsing / matching modules,
for example for XML or other structured data.
Florian octo Forster
Hacker in training
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: Digital signature
Url : http://mailman.verplant.org/pipermail/collectd/attachments/20090820/54675e27/attachment.pgp
More information about the collectd