[yaala] Yaala 0.672: Unavailable aggregation requested: ``requests''.

Juergen Kunkel yaala@verplant.org
Tue, 19 Aug 2003 07:39:12 +0200 (CEST)


Thanks a lot for your help! Now we have solved the problem!

> Hi :)
> On Mon, Aug 18, 2003 at 12:34:58PM +0200, Juergen Kunkel wrote:
>> However, we tried to install Perl 5.6.1 into another directory and
>> changed
>> the Shebang in the yaala code to that, but we still get the same error
>> message.
> Ok, that the problem is something else..
>> And we forgot to mention that we are trying to parse a Squid log file,
>> not
>> Apache. The conf file is ok, that cannot be the problem.
>> It is strange as well that the very same configuration works on another
>> box, even with Perl 5.8.
>> Both boxes have the same OS, the same Perl.
> That sure is strange.. The error message you posted appears, if there
> are no entries for that aggregation. The most common reason for this is,
> when the parser ignores every single line due to a bug. If you turn
> debuging on (set ``$::DEBUG'' in ``yaala'' to ``0x0001'') Squid.pm tells
> you about every line it ignores.

We did this, and this helped us.

> If that is not the case, another possible cause is that no line matches
> your ``where clause''. But I guess you (a) checked that already and (b)
> copied the config to your working machine..
> I can't think of anywhere else in the program where sets of data are
> ignored. So if Squid.pm ignores the lines you propably use a
> squid-configuration which I'm not aware of. In this case I'd love to see
> some of the lines and maybe the relevant lines in your squid
> configuration. However, if Squid.pm does not ignore lines, and you don't
> use where clauses, then there is a really weird problem..

In fact, for some days a colleague had enabled the Apache-style logs in
Squid, and these lines of course could not be parsed by the squid parser.

So, a stupid mistake from our side. Really very sorry for that.