[collectd] Error while executing write_kafka Plugin

BYEONG-GI KIM bgkim at bluedigm.com
Thu Mar 3 09:41:57 CET 2016

Hello. I'm trying to use write_kafka Plugin in order to send the collected
resource data to kafka, but it seems not working correctly. I've met
several troubles while trying to use it as below:

The first problem happened at "make" stage of collectd. I downloaded
librdkafka and collectd from git respectively, and both of branch were
master. I did ./configure, make, and make install for librdkafka and it
seems being done correctly, which means there were no errors while doing
make & make install.

After that, I did same order for collectd, however, there was an error
because the write_kafka.c file used deprecated function,
rd_kafka_set_logger at line 118. I tried to either comment it out or change
the function to rd_kafka_conf_set_log_cb, which is a configuration
alternative of the above one as explained

I then execute collectd with enabling write_kafka plugin, but both of ways
showed very similar errors. At the first case (commenting out the line
118), the collectd at least worked correctly when the IP/DNS for broker(s)
is wrongly set. The collectd tried to reconnect to the wrong IP/DNS
repeatedly. However, if the value is set correctly, an error message was
shown at /var/log/messages like that:  segfault at 0 ip 00007fd7cf72fa25 sp
00007fd7ca2ba7f0 error 4 in write_kafka.so[7fd7cf72d000+7000]

At the second case, i.e., changing the source code of write_kafka.c as I
mentioned, it just showed error like "collectd[24166]: segfault at 180 ip
00007f3d08145fe0 sp 00007f3d07f1ac18 error 6 in
librdkafka.so.1[7f3d08126000+55000]". In the both of error cases, collectd
was automatically shutdown.

Any advice or comments would be really helpful. Thanks in advance!

Best regards

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.verplant.org/pipermail/collectd/attachments/20160303/877b4dc9/attachment.html>

More information about the collectd mailing list