[collectd] varnish plugin, not found

L Cruzero lcruzero at gmail.com
Fri May 23 15:38:06 CEST 2014

Hi, i've been using collectd for a few months to gather based system stats,
recently i've tried unsuccessfully to use the varnish plugin.

on start:


"Starting collectd: Could not find plugin varnish"


There is a `Instance' block within the configuration for the varnish
plugin. The plugin either only expects "simple" configuration statements or
wasn't loaded using `LoadPlugin'. Please check your configuration.


LoadPlugin varnish

<Plugin "varnish">


    CollectCache       true

    CollectConnections true

    CollectBackend     true

    CollectSHM         true

    CollectESI         false

    CollectFetch       false

    CollectHCB         false

    CollectSMA         false

    CollectSMS         false

    CollectSM          false

    CollectTotals      false

    CollectWorkers     false




CentOS release 6.5 (Final)




[root at hssn-dev-el6-03 varnish]# rpm -ql varnish-libs-3.0.5-1.el6.x86_64



[root at hssn-dev-el6-03 varnish]# ls -al /usr/lib64/varnish/

total 332

drwxr-xr-x   3 root root   4096 May 22 11:14 .

dr-xr-xr-x. 45 root root  24576 May 22 14:28 ..

-rwxr-xr-x   1 root root   4800 Dec  2 03:31 libvarnishcompat.so
-rwxr-xr-x   1 root root  81720 Dec  2 03:31 libvarnish.so

i've tried creating soft links under /usr/lib64 as per:

lrwxrwxrwx   1 root root      27 May 23 09:17 libvarnishcompat.so ->
lrwxrwxrwx   1 root root      18 May 23 09:18 libvarnishapi.so ->

[root at hssn-dev-el6-03 lib64]# find . -type f -name "libvarnish*" -print

any possible leads, would be greatly appreciated.

kind regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.verplant.org/pipermail/collectd/attachments/20140523/726b5b4f/attachment.html>

More information about the collectd mailing list