[collectd] Building RPM on AWS - RPATH failures

Dan Fandrich dan at coneharvesters.com
Tue Jan 21 21:29:53 CET 2014

On Tue, Jan 21, 2014 at 08:35:17AM +0000, Dan Scott wrote:
> I've attached the rpmbuild SPEC file. The relevant lines are:
> %build
> %configure --enable-java --with-java=%{java_home}/ --disable-battery
> --disable-rpath
> %{__make} %{?_smp_mflags}

Those macros can hide a lot. What is the actual configure line?  And what are
the actual link lines for one of the binaries that's at issue?
Running ./configure --help | grep rpath doesn't actually show me any such option
as --disable-rpath when I try it.  There is one hard-coded -Wl,-rpath line in
the configure.ac file tha takes effect when linking with libjvm.so. It's
possible that is being used, but it would only be a "standard" location if your
libjvm.so is in /usr/lib or /usr/lib64, etc., which is unlikely. It could be
coming from a pkgconfig source as well. Can you search the config.log file to
see where this is being added?

>>> Dan

> On 20 January 2014 19:43, Dan Fandrich <dan at coneharvesters.com> wrote:
>     On Mon, Jan 20, 2014 at 05:31:37PM +0000, Dan Scott wrote:
>     > I'm trying to build the RPMs of the latest collectd (5.4.0) for AWS
>     Linux.
>     >
>     > I'm basing my .spec file on the existing AWS spec file (5.0).
>     >
>     > The compile and link is running fine, but I'm getting a few failures for
>     RPATH
>     > (below). Anyone have any ideas? I've tried using the disable-rpath option
>     for
>     > the configure, but I still receive the same error.
>     What configure options is this build using?
>     >>> Dan

More information about the collectd mailing list