[collectd] curl_jason plugin is not sending data to rabbitMQ server

Mariano González gonzalez.mariano.gabriel at gmail.com
Thu Feb 6 13:32:56 CET 2014

Hi Marc.

The request I run manually is:

curl -H "X-Auth-Token: my_token"
https://API_url/1.0/account_id/loadbalancers/lb_id/usage/current | python
-m json.tool

And collectd uses the curl_json plugin, which I don't know what it requests
(I assume it uses curl, but I'm not sure how).

Could you guide me on how to tcdump this connections please?

On 5 February 2014 19:42, Marc Fournier <marc.fournier at camptocamp.com>wrote:

> Excerpts from Mariano González's message of 2014-01-31 15:01:13 +0100:
> > Hi there.
> > I've implemented curl_jason plugin to recolect and send LoadBalancer
> > metrics to my RabbitMQ to be graphed in Graphite.
> > Thing is, it's not sending any data, while it is working just fine (and
> > great) with other plugins like memory, cpu, df root, network, etc. I've
> > tried to troubleshoot following this suggestion:
> >
> http://serverfault.com/questions/499378/collectd-stores-nan-instead-of-correct-value-in-ubuntu-12-04
> ,
> > but there're no issues coming out.
> >
> > Here's my collectd.conf: https://gist.github.com/Mariano-gon/8732467
> >
> > Here're the last lines of collectd.log when I start it:
> > https://gist.github.com/Mariano-gon/8732488
> >
> > The request is made against Rackspace API where my LoadBalancer is
> located,
> > and if run manually, the curl gets me a json response perfectly normal.
> Just a random guess: does the rackspace API require you to send an "Accept"
> encoding header ? By default collectd doesn't send any.
> Try tcpdumping the HTTP traffic and compare what headers collectd sends vs
> when you run curl manually.
> Marc

Mariano Gabriel González
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.verplant.org/pipermail/collectd/attachments/20140206/174a0d3f/attachment.html>

More information about the collectd mailing list