[collectd] postgresql plugin query help

Andrew Hammond andrew.george.hammond at gmail.com
Thu Mar 28 22:20:10 CET 2013

Hi all,

I have a working collectd setup publishing to graphite. I have the default
postgresql queries working against a postgres database. I want to add the
following query. https://gist.github.com/ahammond/811b3532f229bc4ec386 It
doesn't appear to be generating any data. The existing default queries
continue working, and I don't get any error messages either in syslog or on
the console when I run it there directly.

I've tested the query in the database and it runs error free. I've tried
adding a ; to the end of the Statement string and putting single-quotes (')
around the $1 parameter. Neither of these things seem to have any effect.

What are my next steps to get this working please?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.verplant.org/pipermail/collectd/attachments/20130328/2764956c/attachment.html>

More information about the collectd mailing list