[collectd] collectd: rrdcached plugin: rrdc_update failed with status -1

Zhou, Yuantai yuantai.zhou at intel.com
Thu Jul 18 19:09:30 CEST 2013

Hi Yves,
Thanks for replying.

For collectd server, we are using version Version: 5.1.0-3ubuntu1. For collectd clients, we are using version Version 4.10.1-2.1ubuntu7. We see same error on both systems.

Tried only using RRDCached plug-in, same error happens. I tested the permissions with everyone has read\write permission to /var/lib/rrdcached/db/collectd, it still has the same error. We don't have a collectd or rrdcached account in /etc/passwd.

One question:  if we just use RRDTool plugin, do we get same rrd file caching as RRDCached plugin? If not, what are the differences?


-----Original Message-----
From: collectd-bounces at verplant.org [mailto:collectd-bounces at verplant.org] On Behalf Of Yves Mettier
Sent: Wednesday, July 17, 2013 11:28 PM
To: collectd at verplant.org
Subject: Re: [collectd] collectd: rrdcached plugin: rrdc_update failed with status -1


Please provide the version number of the collectd you are using. 
Sometimes, it helps.

For what I can say now, I think that you should not use both rrdcached and rrdtool.
If you use rrdcached, do not forget to add "CreateFiles true".

Also check that collectd (and rrdcached if you are using it) has the permissions to go to /var/lib/rrdcached/db/collectd and then to write files there.

More info here :
https://collectd.org/wiki/index.php/Plugin:RRDCacheD (this one should be


Le 2013-07-17 23:55, Zhou, Yuantai a écrit :
> Hi All,
> We want to use the RRDCached plugin in our collectd environment but we
> are seeing a lot of errors in syslog from collectd servers (and
> collectd clients) like the following:
> rrdcached plugin: rrdc_update
> (/var/lib/rrdcached/db/collectd/xxxxxxxxxxx/df/df-root.rrd,
> [1374097922:0.000000:0.010000:0.050000], 1) failed with status -1.
> The error appears to happen for every rrd file
> The RRDCached plugin configurations is as follows:
> <Plugin rrdcached>
>         DaemonAddress "unix:/var/run/rrdcached.sock"
>         DataDir "/var/lib/rrdcached/db/collectd"
>         CollectStatistics true
> </Plugin>
> <Plugin rrdtool>
>         DataDir "/var/lib/rrdcached/db/collectd"
>         CacheTimeout 60
>         CacheFlush 3600
>         WritesPerSecond 1800
>         RandomTimeout 30
> </Plugin>
> We do see that the RRD files (at least some or most of them) are being
> updated (with new timestamps).
> Any way to resolve the error?
> Thanks.
> Yuantai
> _______________________________________________
> collectd mailing list
> collectd at verplant.org
> http://mailman.verplant.org/listinfo/collectd

- Homepage       - http://ymettier.free.fr                             -
- GPG key        - http://ymettier.free.fr/gpg.txt                     -
- C en action    - http://ymettier.free.fr/livres/C_en_action_ed2.html -
- Guide Survie C - http://www.pearson.fr/livre/?GCOI=27440100673730    -

collectd mailing list
collectd at verplant.org

More information about the collectd mailing list