[collectd] Compiling 5.0 on Ubuntu 11.04

Bill Harris savoy9020 at texoma.net
Wed May 4 18:04:17 CEST 2011

Hmm, not very familiar with git..

I tried a "git clone git://github.com/octo/collectd.git"
but it didn't have a configure file, so tried with "autoconf"

That didn't work to well either.
The daily builds don't appear to be working.. Is there a recent
daily build somewhere else I could get?

I did see where the supplied iptc was removed.. recently.


On 5/3/11 12:15 PM, "Francois-Xavier Bourlet"
<francois-xavier.bourlet at dotcloud.com> wrote:

> if you are compiling from the latests sources, you can still checkout
> to the latest but one commit, and try again to build. Pay attention
> that clean.sh do not clean everything. you would like to checkout in a
> empty directory before building.
> On Tue, May 3, 2011 at 6:51 AM, Bill Harris <savoy9020 at texoma.net> wrote:
>> Is there a patch to fix this iptc issue with collectd on Ubunutu Server
>> (11.04) i386?
>> Bill
>>  gcc -DHAVE_CONFIG_H -I. -I. -I../../src -Wall -Werror -g -O2 -c libip4tc.c
>>  -fPIC -DPIC -o .libs/libip4tc.o
>> In file included from libip4tc.c:136:0:
>> libiptc.c:84:8: error: redefinition of Œstruct xt_error_target¹
>> /usr/include/linux/netfilter/x_tables.h:69:8: note: originally defined here
>> make[3]: *** [libip4tc.lo] Error 1
>> make[3]: Leaving directory `/home/bharris/work/collectd-5.0.0/src/owniptc'
>> make[2]: *** [all-recursive] Error 1
>> make[2]: Leaving directory `/home/bharris/work/collectd-5.0.0/src'
>> make[1]: *** [all] Error 2
>> make[1]: Leaving directory `/home/bharris/work/collectd-5.0.0/src'
>> make: *** [all-recursive] Error 1
>> _______________________________________________
>> collectd mailing list
>> collectd at verplant.org
>> http://mailman.verplant.org/listinfo/collectd

More information about the collectd mailing list