[collectd] A few problems and suggestions

Marco Chiappero marco at absence.it
Tue Mar 18 21:22:59 CET 2008

Florian Forster ha scritto:
> If you use a pre-compiled package: Where did you get it from? The
> current `unstable' package (Debian Sid) is linked with libsensors3
> (1:2.10.3-1), so it's not surprising that this binary doesn't work with
> libsensors4.

I'm using the official debian packages. I'm running debian testing but I 
installed the collectd package (+ collectd-dbg) from sid since there are 
no dependencies issues and it's the last version.

> If the daemon stays uncommunicative, get your hands on a version that
> has debugging capabilities. You can get them by specifying
> `--enable-debug' when configuring the source. (The experimental Debian
> package used to have debugging enabled, but the unstable package doesn't
> anymore, so Sebastian tells me.) Increase the verbosity by setting the
> log level to `debug' and re-run the daemon. If still no output appears,
> you should probably go and see a optician ;)

I installed the collectd-dbg package and enabled the "LoadPlugin 
logfile" entry ecc... Nothing useful, just this output:

root at vulcano:~# collectd -C /etc/collectd/collectd.conf -f
[2008-03-18 21:05:23] cpufreq plugin: Found 1 CPU
[2008-03-18 21:10:13] Exiting normally

>>> What can _we_ do different here? IIrc the hddtemp plugin simply
>>> connects to and reads from the hddtempd using a socket.
>> Maybe you can help me to understand why polling the server with a bash
>> script doesn't affect the drives standby command after some time of
>> inactivity like the hddtemp plugin does. It seems that it keeps
>> accessing the drives. I'm not blaming you, I'd just like to understand
>> why.
> I don't know either, sorry :/ Did you check hddtemp's manpage? A quick
> search produces this bug report, but unfortunately it doesn't seem to be
> resolved: <https://savannah.nongnu.org/bugs/?19150>

I found this taking a look at the /etc/init.d/hddtemp script:

"if /usr/sbin/hddtemp -wn $OPTIONS $disk 2>/dev/null"

and from the hddtemp manpage:

-w, --wake-up
               Wake-up the drive if needed (ATA drives only)

Maybe this keeps drives active. I'll try to change it.
By the way, did you receive the other mail about this issue?

Ok, so:
- sensors problem --> solved soon
- hddtemp  --> not a collectd problem (however I'll try to use a script 
for collecting hdds temp data as well)
- ping not working --> still a mistery

On another machine running ubuntu, with both collectd and collectd-ping 
3.10, ping plugin works fine... it's a little bit strange.

However thank you for your help!


More information about the collectd mailing list