[collectd] First time user of collectd 4.2.1: Issue with exec pluggin

Florian Forster octo at verplant.org
Sat Nov 10 11:49:58 CET 2007

Hi Jeff,

On Fri, Nov 09, 2007 at 02:53:27PM -0500, jeff nad wrote:
> Im trying to use the exec pluggin to push custom metrics into
> collectd.

I've tried your sample script and it worked without a problem for me. So
the script output should be fine.

> My simple test case does not work and nothing is logged to syslog.

Debugging output is disabled at compiletime, unless you use
``--enable-debug'' when running the configure script. Then you should
get debugging output like this:
-- 8< --
 [2007-11-10 10:33:15] exec plugin: exec_read_one:
   buffer = qcaste01/cpu-0/cpu-idle N:2299388
 [2007-11-10 10:33:15] plugin: plugin_dispatch_values:
   time = 1194687195; interval = 10; host = qcaste01; plugin = cpu;
   plugin_instance = 0; type = cpu; type_instance = idle;
-- >8 --

> This little scripts is run and I expect the metrics to appear under
> /opt/collectd/var/lib/collectd/qcaste01. Metrics gererated by default
> pluggins works. I see the shell script being forked and executed.

This sounds very weird and I have no idea what might be the problem
here.. Could you please re-compile with debugging output and then but a
couple of lines (500 or so should be sufficient) on a webserver

> My collectd.conf has only the syslog/logfile/exec pluggins enabled.

Without an output plugin such as `rrdtool' or `csv' nothing will be
written to disk. But since you say that other metrics are getting
written I assume you have one of these loaded, too..

Florian octo Forster
Hacker in training
GnuPG: 0x91523C3D
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://mailman.verplant.org/pipermail/collectd/attachments/20071110/d39b396b/attachment.pgp 

More information about the collectd mailing list