[collectd] cannot load Perl plug-in: plugin_load: Could not find plugin "perl" in /usr/lib64/collectd

Dan NH dannh1776 at gmail.com
Fri May 22 23:21:21 CEST 2015

Good evening!

*Issue*: cannot load Perl plug-in
*Error message from*: /var/log/collectd.log
*error message text*:
[2015-05-22 13:07:02] plugin_load: Could not find plugin "perl" in
[2015-05-22 13:07:02] Found a configuration for the `perl' plugin, but the
plugin isn't loaded or didn't register a configuration callback.

*System information:*
centOS 6

*collectd version:*
collectd              x86_64 5.4.1-1.el6

I am installing this from a repository.

*The plug-in is the example from the source repository*:

*Maybe this installation could not find libperl.so…*

*I tried putting a symbolic link, but I got the same error:*
bash-4.1# pwd
bash-4.1# ls -l *perl.so
lrwxrwxrwx 1 root root 65 May 22 16:04 libperl.so ->

*This is from my collectd configuration file:*
<Plugin perl>
       IncludeDir "/usr/local/lib64/perl5"
       BaseName "Collectd::Plugins"
       EnableDebugger ""
       LoadPlugin MyPlugin

       <Plugin MyPlugin>

*Plug-in location:*
# ls /usr/local/lib64/perl5
MyPlugin.pm  TestPlugin.pm

I tried to enable the debugger but control never passes to the Perl
debugger. Maybe not surprising if it cannot find this necessary Perl

Please offer any advice. A possible solution someone may know about is a
special environment variable that can point to different libraries for
collectd after configuration.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.verplant.org/pipermail/collectd/attachments/20150522/8edfa333/attachment-0001.html>

More information about the collectd mailing list