[collectd] Compiling collectd with write_mongodb plugin support

Giovanni Torres giovtorres at hotmail.com
Fri Apr 11 20:34:31 CEST 2014

I need some help compiling the write_mongodb plugin.  I am using Scientific Linux 6.5.  I successfully compiled the mongo-c-driver.  When I run $(CPPFLAGS=-I/usr/local/mongo-c-driver/include/libmongoc-1.0 ./configure --enable-write_mongodb), it fails saying that there is a dependency error.

Looking at config.log, I get the following error:
  configure:21546: checking for mongo.h
  configure:21546: gcc -c -g -O2 -I/usr/local/mongo-c-driver/include/libmongoc-1.0  conftest.c >&5
  conftest.c:182:19: error: mongo.h: No such file or directory

Why is it looking for mongo.h and not mongoc.h?  I tried looking for mongo.h from some of the available mongodb RPMs, but I can't seem to find it.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.verplant.org/pipermail/collectd/attachments/20140411/67346d6b/attachment.html>

More information about the collectd mailing list