[collectd] running on mips

Franklin, Dave Dave.Franklin at arrisi.com
Mon Oct 7 22:08:07 CEST 2013

I just downloaded version 5.4 and I am having trouble seeing much output when I run collectd in an x86 mips-linux environment. I am fairly certain that configure and make ran without problems (no errors). I may have not correctly performed the "install".

configure was run with --host=mipsel-linux CC=/my/toolchain/compiler/mipsel-unknown-linux-gnu-gcc --with-fp-layout=intswap --exec-prefix=/varbackup --prefix=/my/homedir/temp

make was run with CC=/my/toolchain/compiler/mipsel-unknown-linux-gnu-gcc LD=/my/toolchain/linker/mipsel-unknown-linux-gnu-ld all

After the build, did an install to a temporary directory on my host system (redhat x86 linux) and then tarred and gzipped everything under --prefix and copied to my target platform, then unzipped and extracted. My collectd.conf has BaseDir, PIDFile, PluginDir and TypesDB uncommented and pointing to the appropriate location (based on where I unzipped/extracted). I use /varbackup only because it's a safe partition for me to play with on the target, with plenty of space.

I have the standard input plugins also uncommented in the .conf file (memory, cpu). Interval is set to 10. The logfile plugin is set to log info to filename "/varbackup/foo".

I am logged as root on the target platform.

When I run /varbackup/sbin/collectd -t -C /varbackup/etc/collectd.conf, no errors are reported.
But when I run /varbackup/sbin/collectd -C /varbackup/etc/collectd.conf -f
 : no output on stdout
: in file "foo" I only see "[  <timestamp>  ] Initialization complete, entering read-loop."
with obviously the correct timestamp in square bracket - but no other logging at all of any kind.

I wonder if the input plugins are not quite working?
Thanks in advance,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.verplant.org/pipermail/collectd/attachments/20131007/ceddbcb9/attachment.html>

More information about the collectd mailing list