[collectd] RHEL6 - Network plugin KO

Benjamin Dupuis poil at quake.fr
Tue Oct 9 18:18:09 CEST 2012


I'm using collectd 4.10.7
We have 2000 nodes in RHEL5 or Ubuntu 10.04 to 12.04
Our collectd network server is a RHEL5 with rrcached (homemade RPM)
All is working fine

Now we are trying to add RHEL6
I've first tried with the EPEL package, it's working on local (plugin rrdtool) but not in network.
RRDs files are created but stay empty (NaN)

So I've tried to build from scratch collectd 4.10.7 with debug enabled (not linked with libgcrypt) and I've the same results

When I run a tcpdump on client and server, there's some frame on the 2 sides (client send to server, server receive)

I've tried to disable selinux ...tried to run a client and a server on a RHEL6 and I've the same result.

So it's outside my skill, if anybody have an idea, I've attached the log of my client side, and the configuration file.

Best regards,
-------------- next part --------------
A non-text attachment was scrubbed...
Name: collectd.conf
Type: application/octet-stream
Size: 21091 bytes
Desc: not available
URL: <http://mailman.verplant.org/pipermail/collectd/attachments/20121009/a5623142/attachment-0002.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: debug_collectd.log
Type: application/octet-stream
Size: 24970 bytes
Desc: not available
URL: <http://mailman.verplant.org/pipermail/collectd/attachments/20121009/a5623142/attachment-0003.obj>

More information about the collectd mailing list