[collectd] Notifications not working

Stian Øvrevåge sovrevage at gmail.com
Mon Nov 5 13:31:24 CET 2012

Hi list, trying to configure notifications but I find the
documentation quite confusing.

My current non-working test config looks like this:

>From collectd.conf:

LoadPlugin exec
<Plugin exec>
  NotificationExec "user" "echo 'notification' >> /home/user/notiftest"

LoadPlugin snmp
<Plugin snmp>

  <Data "cisco_cpu">
    Type "cisco_cpu"
    Table true
    Values "CISCO-PROCESS-MIB::cpmCPUTotal5secRev"

  <Host "test-switch">
    Address ""
    Version 2
    Community "public"
    Collect "cisco_cpu"
    Interval 60


  <Host "test-switch">
    <Plugin "snmp">
      <Type "cisco_cpu">
        Instance "1"	// Tried with and without this
         WarningMin    0.00
         WarningMax 8.00
         FailureMin    0.00
         FailureMax 12.00
         DataSource "cpu5sec" // Tried with and without this

The data is collected fine from the switch:

rrdtool lastupdate cisco_cpu-1.rrd
 cpu5sec cpu1min cpu5min
1352118105: 22.000000 10.000000 9.000000

But nothing is written to the notiftest-file so I'm assuming the
command is not executed.

I'm running collectd in foreground but it gives no errors there, nor
in the syslog.

Stian Øvrevåge

More information about the collectd mailing list