[collectd] bind plugin syslog messages

Vincent McIntyre vincent.mcintyre at gmail.com
Tue Jul 31 02:38:34 CEST 2012

Running 4.10.1-1+squeeze2 on debian squeeze. This is a client system.
The server is running a backport, 4.10.1-1+squeeze1~bpo50+1.

I haven't found any bug reports on b.d.o so I am assuming I am doing
something wrong.

I turned on the bind plugin today in collectd.conf.

+LoadPlugin bind
+<Plugin "bind">
+  URL "http://localhost:8053/"
+  OpCodes         true
+  QTypes          true
+  ServerStats     true
+  ZoneMaintStats  true
+  ResolverStats   false
+  MemoryStats     true
+  <View "_default">
+    QTypes        true
+    ResolverStats true
+    CacheRRSets   true
+    Zone "127.in-addr.arpa/IN"
+  </View>

and updated /etc/bind/named.conf.local
+statistics-channels {
+  inet port 8053;

I see data accumulating on the collectd server.

The problem I have is that in syslog I am seeing lots of:
collectd[11114]: plugin_dispatch_values: Dataset not found: dns_qtype_gauge
6 entries every 10 seconds.

I checked on the client system
% grep types /etc/collectd/*.conf
/etc/collectd/collectd.conf:TypesDB "/usr/share/collectd/types.db"

% grep dns_qtype /usr/share/collectd/types.db
dns_qtype_cached        value:GAUGE:0:4294967295
dns_qtype               value:COUNTER:0:65535

(same result on the server system).

I checked with stat(1) that the file was indeed being read on startup.

I tried swapping out the types.db on the client and using the latest from git
% grep dns_qtype /usr/share/collectd/types.db
dns_qtype_cached        value:GAUGE:0:4294967295
dns_qtype               value:DERIVE:0:U

But I get exactly the same behaviour.

Is this a known issue or a new one?

Kind regards

More information about the collectd mailing list