[collectd] Unable to load Plugin amqp -- cannot find dependency librabbitmq.so

Anna Shen annashenwx at gmail.com
Thu Jan 19 06:24:39 CET 2012

Hi there,

I am pretty new to collectd and have carefully read collectd official FAQ
and spent significant time over internet for possible solutions and have
tried all of them. I still cannot find a working solution.

I am trying to configure the collectd so that it can collects metrics data
and publish them to an external rabbitmq server.  I found amqp plugin and
did the following:

1. install collectd from https://github.com/octo/collectd.git
2. *install rabbitmq from https://github.com/rabbitmq/rabbitmq-c
3. re-configure /opt/collectd/etc/collectd.conf by un-commenting amqp
plugin body
4. ./configure
5. restart collectd by execute "/opt/collectd/sbin/collectd"

all went well until i hit 5. I got the following error message:

*root at server-32615:~# /opt/collectd/sbin/collectd*
*ERROR: lt_dlopen ("/opt/collectd/lib/collectd/amqp.so") failed: file not
found. The most common cause for this problem are missing dependencies. Use
ldd(1) to check the dependencies of the plugin / shared object.*
*Unable to load plugin amqp.*
*root at server-32615:~# ldd /opt/collectd/lib/collectd/amqp.so*
*        linux-vdso.so.1 =>  (0x00007fff06f47000)*
*        librabbitmq.so.0 => not found*
*        libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fee7c439000)
*        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fee7c0a4000)*
*        /lib64/ld-linux-x86-64.so.2 (0x00007fee7c84b000)*
I did make a symbolic link for librabbitmq, see below:

root at server-32615:/opt/collectd/lib/collectd# ls -al
total 5076
drwxr-xr-x 2 root root   4096 2012-01-17 19:24 .
drwxr-xr-x 5 root root   4096 2012-01-17 07:50 ..
-rw-r--r-- 1 root root 114690 2012-01-17 07:50 amqp.a
-rwxr-xr-x 1 root root    941 2012-01-17 07:50 amqp.la
-rwxr-xr-x 1 root root  79686 2012-01-17 07:50 amqp.so
-rw-r--r-- 2 root root 447538 2012-01-17 07:11 librabbitmq.a
-rwxr-xr-x 2 root root    971 2012-01-17 07:11 librabbitmq.la
lrwxrwxrwx 2 root root     20 2012-01-17 07:11 librabbitmq.so ->
lrwxrwxrwx 2 root root     20 2012-01-17 07:11 librabbitmq.so.0 ->
-rwxr-xr-x 2 root root 284712 2012-01-17 07:11 librabbitmq.so.0.0.0

for the librabbitmq.so file I copied from /usr/local/bin

I just do not understand why collectd cannot recognize librabbitmq.so

by the way, i tried install collectd 5.0.1 from .tar,  and collectd 4.x.x
using apt tool, no luck either... by the way, the collectd from the git
source i cloned has a version tag 5.0.0, something wrong?

Can someone please help me figuring out what is missing from the picture.
Thank you so much .


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.verplant.org/pipermail/collectd/attachments/20120118/c3a8778a/attachment.html>

More information about the collectd mailing list