[collectd] Apache graphs don't render in collectd 5.0.2

Jacek Osiecki vjosh at silvercube.pl
Fri Feb 10 16:58:51 CET 2012


I have been checking the possibilities of collectd lately. Finally
found the tool that does what I need... :)

However, when I was discovering various collectd plugins and versions
(depending on mysql and apache versions on my servers), I found out
that there is a problem with apache plugin on servers where I use
version 5.0.2.

Simply, the apache graphs do not show up. Instead, when I use 
CGI, I see in the apache logs:

[Fri Feb 10 01:11:51 2012] [error] [client] [Fri Feb 10 
01:11:51 2012] collection.cgi: RRDs::graph: No DS called 'count' in
at /usr/share/collectd/cgi-bin/collection.cgi line 787., referer: (...)

and my apache.conf for collectd is as simple as possible:

<Plugin apache>
         <Instance "apache80">
         URL ""

The address is the address of local vserver.
On the other hosts, where I use version 4.9 - everything works great.

Any suggestions? I have tried some other interfaces like cgp - no 
errors (probably hidden)
but still graphs don't show up :(

I tried collectd-web, but I'm still getting some problems with 
launching it.

Best regards,
Jacek Osiecki
Silvercube s.c.
ul. Makuszyńskiego 4, 31-752 Kraków
tel/fax: +48 (12) 684 21 00

More information about the collectd mailing list