[collectd] collectd genericJMX - Shutdown issue

Dennis Brandenburg d.brandenburg at db-network.de
Mon Dec 10 12:55:09 CET 2012


after I built collectd-java plugin against
openjdk- on Centos everything works fine on
loading the java plugin and on loading "org.collectd.java.GenericJMX".
Listval shows me values of heapsizes, classes, etc as expected. But when
stopping collectd the plugin seems to stop abnormally, because the runfile
of the Unixplugin for example isn't deleted, which means other plugins
aren't shutdown properly. That only happens when
"org.collectd.java.GenericJMX" is being loaded. By running the plugin-test
(collectd -T), the process just hangs with the following output:

Exiting normally.
org.collectd.java.GenericJMX.Shutdown ();

I also tried to compile against jdk1.6.0_37 sun-jdk: Same issue. All tries
with collectd 5.1.0 and also with latest collectd version 5.2.0.

My /etc/collectd.conf looks like this:

Interval 180
Timeout 120
FQDNLookup true

Include "/etc/collectd.d/*.conf"

I reduced the java Plugin on a minimum to even not store any values, where
I still get the issue. As far as I remove 'LoadPlugin
"org.collectd.java.GenericJMX"', collectd -T runs without any problems and
the daemon stops all other plugins properly. java.conf:

LoadPlugin java

<Plugin "java">
  JVMArg "-Djava.class.path=/opt/collectd/lib/collectd/bindings/java"
  JVMArg "-Xmx64m"
  LoadPlugin "org.collectd.java.GenericJMX"


Did someone have similar issues with the GenericJMX plugin? Any ideas what
I could test further or what could be the root cause?

Thanks and regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.verplant.org/pipermail/collectd/attachments/20121210/4d291b21/attachment.html>

More information about the collectd mailing list