[collectd] Issue With Graphite Perl Plugin

Tom Purl tom at tompurl.com
Wed Jul 6 03:56:43 CEST 2011

Hi, I'm a new collectd user and I'm having an issue that is either
related to the perl plugin or the collectd-graphite plugin. I've tried
a few different versions of collectd (5.0 and 4.10) and searched the
mailing lists, but I haven't been able to figure this problem out.

I'm running version 5.0 on Ubuntu 10.4. I compiled from source, and I
am able to successfully run collectd with the following config:

Hostname    "localhost"
FQDNLookup   true
BaseDir     "/opt/collectd/var/lib/collectd"
PIDFile     "/opt/collectd/var/run/collectd.pid"
PluginDir   "/opt/collectd/lib/collectd"
TypesDB     "/opt/collectd/share/collectd/types.db"
Interval     10
Timeout      2
ReadThreads  5
LoadPlugin syslog
LoadPlugin logfile
<Plugin logfile>
        LogLevel info
        File STDOUT
        Timestamp true
        PrintSeverity false
<Plugin syslog>
        LogLevel info
LoadPlugin cpu
LoadPlugin interface
LoadPlugin load
LoadPlugin memory
LoadPlugin rrdtool

I then tried to use the collectd-graphite plugin
(https://github.com/joemiller/collectd-graphite). It uses the perl
plugin, so I added the following to my config file:

LoadPlugin perl
<Plugin "perl">
        IncludeDir "/usr/local/share/perl/5.10.1"
        BaseName "Collectd::Plugins"
        LoadPlugin "Graphite"
        <Plugin "Graphite">
          Buffer "256000"
          Prefix "servers"
          Host   "localhost"
          Port   "2003"

I know that I didn't set the Global property to "true", but from what
I understand, that's not necessary in the 5.0 version of collectd.

Then, when I try to start collectd, I get the following errors:

[2011-07-05 20:42:31] plugin_load_file: The global flag is not
supported, libtool 2 is required for this.
[2011-07-05 20:42:31] perl: Initializing Perl interpreter...
Can't locate Collectd.pm in @INC (@INC contains:
/usr/local/share/perl/5.10.1 /etc/perl /usr/local/lib/perl/5.10.1
/usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5
/usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .).
BEGIN failed--compilation aborted.
[2011-07-05 20:42:31] perl: init_pi: Unable to bootstrap Collectd:
Can't locate Collectd.pm in @INC (@INC contains:
/usr/local/share/perl/5.10.1 /etc/perl /usr/local/lib/perl/5.10.1
/usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5
/usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .).
BEGIN failed--compilation aborted
[2011-07-05 20:42:31] perl: Configuration failed with a fatal error -
plugin disabled!
[2011-07-05 20:42:31] Initialization complete, entering read-loop.
[2011-07-05 20:42:31] rrdtool plugin: Adjusting "RandomTimeout" to
0.000 seconds.

Here's the contents of my "/usr/local/share/perl/5.10.1" directory:


These files should be readable by the collectd daemon because it is
running as root.

So it appears to me that collectd can't find Collectd.pm in
/usr/local/share/perl/5.10.1, but that should be ok since a Collectd
folder is in there, right?

Does anyone have any idea what I'm doing wrong? Is this an issue with
the perl plugin, or should I contact the author of the
collectd-graphite plugin?

Thanks in advance!

Tom Purl

More information about the collectd mailing list