[collectd] Unable to load plugin iptables

Romain Riviere mr-smoke at spinning-plates.eu.org
Thu Dec 29 10:40:22 CET 2011

Hello list,

As suggested on IRC, I'm posting here to report a problem with the 
iptables plugin.
I have tried collectd 5.0.1 from source, the 5.0.1 Gentoo ebuild, and 
4.10.4 from source, with the same result:

ERROR: lt_dlopen ("/opt/collectd/lib/collectd/iptables.so") failed: 
file not found. The most common cause for this problem are missing 
dependencies. Use ldd(1) to check the dependencies of the plugin / 
shared object.
Unable to load plugin iptables.

The file exists in all cases, and ldd dependencies are all met. strace 
reveals nothing particularly wrong with the loading of the module:
(note: the path to iptables.so is different here, this is from the 
Gentoo ebuild whereas the above is from source)

[pid   870] open("/usr/lib/collectd", 
[pid   870] getdents64(3, /* 13 entries */, 32768) = 408
[pid   870] lstat64("/usr/lib/collectd/iptables.so", 
{st_mode=S_IFREG|0755, st_size=9288, ...}) = 0
[pid   870] open("/usr/lib/collectd/iptables.so", O_RDONLY) = 4
[pid   870] read(4, 
512) = 512
[pid   870] fstat64(4, {st_mode=S_IFREG|0755, st_size=9288, ...}) = 0
[pid   870] mmap2(NULL, 12316, PROT_READ|PROT_EXEC, 
MAP_PRIVATE|MAP_DENYWRITE, 4, 0) = 0xb7551000
[pid   870] mmap2(0xb7553000, 8192, PROT_READ|PROT_WRITE, 
[pid   870] close(4)                    = 0
[pid   870] munmap(0xb7551000, 12316)   = 0

The system is running a monolithic Linux-VServer kernel, version on i686, with PaX (but no untoward flags on 

I am quite at a loss to explain and solve this issue, any pointers 
would be appreciated.


More information about the collectd mailing list