[collectd] Compiling 5.0 on Ubuntu 11.04 still failed

Amer stalkerboi at gmail.com
Tue Aug 23 18:59:33 CEST 2011


Did anyone successfully compile collectd 5.0 source on Ubuntu 11.04? I
can't compiled the source without getting these errors which then
halted the compiling process half way through

Making all in owniptc
make[3]: Entering directory `/root/collectd/src/owniptc'
/bin/bash ../../libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H
-I. -I../../src    -Wall -Werror -g -O2 -c -o libip4tc.lo libip4tc.c
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I../../src -Wall -Werror
-g -O2 -c libip4tc.c  -fPIC -DPIC -o .libs/libip4tc.o
In file included from libip4tc.c:136:0:
libiptc.c:84:8: error: redefinition of 'struct xt_error_target'
/usr/include/linux/netfilter/x_tables.h:69:8: note: originally defined here
make[3]: *** [libip4tc.lo] Error 1
make[3]: Leaving directory `/root/collectd/src/owniptc'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/root/collectd/src'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/root/collectd/src'
make: *** [all-recursive] Error 1

I saw someone bring up the same issue before here
and it was suggested to use the fresh source pulled directly from your
git. I've given that a go but unfortunately it still fail to compile
with same error.

Any idea?

More information about the collectd mailing list