[collectd] lua plugin

Schmurfy schmurfy at gmail.com
Sun Nov 28 16:30:10 CET 2010

It works now thanks.

I finally managed to compile a working lua plugin on my system the only
problem I had is that the pkg-config package is called "lua" for me with 5.1
as its version, I tried to change the configure.in script to handle both
cases but I gave up after half an hour on this and simply changed the lines
on my local branch:

$PKG_CONFIG --exists lua5.1 2>/dev/null
$PKG_CONFIG --exists "lua >= 5.1" 2>/dev/null

I have working read and write callbacks as well as a dispatch_notification
method and I am working on notification callback, I implemented read/write
callbacks the way I intended to:
The plugins can define a function with a specific name which, if defined,
will be called by the lua plugin on these events, now the question I want to
ask is do you really think the added complexity of the C code is really
worth what it brings to the lua side ? (there are something like 80 lines
differences and the complexity is in no way comparable)
Here is and example with both ways of doing it:
case1 is yours, case2 is mine.

While I am really thankful for the help on the build system problems I can
have and will surely continue to have and on other matters I asked help for
I am more than disappointed by the way you took over my plugin, to give you
a concrete example of how I feel: I asked you for help painting a wall and
you ended changing my doors and adding a wall in the middle of my living
room :p
I am not angry at you (and I hope you won't be at me for being so direct) in
any way but i want to work myself on my plugin, even if it means struggling
with some problems you could solve in 5min due to my lack of knowledge on
the collectd internals.

It is really nice that you are always there to provide help but if you could
just refrain yourself a little I would be far more at ease :)
(I am not speaking about fixes and improvements on my code here but
additions which do not go where I wanted te plugin to go)

Julien Ammous

On 26 November 2010 22:51, Florian Forster <octo at collectd.org> wrote:

> Hey,
> On Fri, Nov 26, 2010 at 09:46:40PM +0100, Schmurfy wrote:
> > I tried your branch but sadly I cannot build it, a dependency was
> > added which does not exists under Mac OS X (clock_gettime):
> I did some digging and apparently Mac OS X really doesn't have
> clock_gettime(2), it's not just a special define required or something
> like that.
> I implemented a fallback using gettimeofday(2) which, hopefully, is
> available everywhere. That function has been deprecated, so it *must* be
> in widespread use, right? ;)
> Hope this helps :)
> —octo
> --
> Florian octo Forster
> Hacker in training
> GnuPG: 0x0C705A15
> http://octo.it/
> Version: GnuPG v1.4.9 (GNU/Linux)
> Gl1vUwsgw4TPDW5NzivzM0plpu743G6iLzuXiVUlDGF5F9vuzilPNZSFVpxLl1Mc
> OHrqRc2CscjUQ1nGC5C25QIJiObJ84/LHPSVAS7YYo8/eNQk2PpFKQ11qYeQ/iBO
> PRdTsR7G9yM49WbZqOI6c79R3QTsRMeXgFH7JGjxbfjHX3X/OQVCSFYoAeQ+feNe
> h/DqYU8Gcvc2Yw/rJ1N6cHafuaMt+EfR6QX9jCGf40p8i3y8zqR7i57zSgGfQzBL
> 1OSpfLtLkwqjxaA4k1KoiLf3U6E+BX2pRO1vM5PXrFNTVRSPEY9M3yxU+ngCfGIC
> BX0f71Lg89HmnE254Y455av1fqG2z5eIU1a1ziYhMaWzkO3wrCuakOeKd7HUh0Us
> bipObON7XET8ypmINXtFssJlVcNasjdkJUorbvj1KTCcZKvY9DHrgBSVuoquoWbh
> Mb7+9qZ2fb4PLwT57Tv2f9CpAbH/hOSy/+Vgvkn7oDCKtdQ5vggHQHVVYcVswhwe
> AIuezUJaPMvSX98DKMOz7IrtsO2E2WuT/SHjbN2RbePZhBQpJwpNbj/x9C0JYiIv
> 8GDYid317MH2t6JDdELe0vbZQcffIFbtiysd3ymkl7WAT+WWAby2/bb2temYpC14
> =wjPe
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.verplant.org/pipermail/collectd/attachments/20101128/413f869f/attachment.htm>

More information about the collectd mailing list