[collectd] [PATCH] Bugfix: correctly handle spurious wakeups in pthread_cond_timedwait
michael+collectd at stapelberg.de
Wed Feb 10 15:42:11 CET 2010
Thanks for merging.
Excerpts from Florian Forster's message of Mi Feb 10 12:22:10 +0100 2010:
> I've done a minor modification: Rather than using "bool" I've changed
> the "timeout_reached" to return "_Bool" which is a basic data type in
C99 also includes stdbool.h, which defines "bool" as an alias for "_Bool".
So you did not need to change that, and bool is more readable than _Bool
IMO ;-). But I don’t want to start a discussion on code style, I just
wanted to make sure you know about stdbool.h. So feel free to leave it
like it is or change it.
More information about the collectd