[collectd] Can't locate Collectd/Unixsock.pm in @INC

Sebastian Harl sh at tokkee.org
Mon Aug 23 14:17:29 CEST 2010


On Mon, Aug 23, 2010 at 08:06:30PM +0800, Salimane Adjao Moustapha wrote:
> On Mon, Aug 23, 2010 at 7:14 PM, Sebastian Harl <sh at tokkee.org> wrote:
> > On Mon, Aug 23, 2010 at 05:57:53PM +0800, Salimane Adjao Moustapha wrote:
> > > I am trying to get collection3 to work on CentOS 5.5. Here is the
> > > error message I get when I go to
> > > http://localhost/collection3/bin/index.cgi:
> > >
> > > Software error:
> > >
> > > Can't locate Collectd/Unixsock.pm in @INC (@INC contains: ../lib
> > […]
> >
> > How did you install collectd? collectd ships Collectd/Unixsock.pm in
> > bindings/perl/ and should install it to whatever your local Perl
> > installation thinks is the right place (which should be some directory
> > in @INC, I suppose).

> Thanks for the reply. first i've installed it from source, i'm on centos
> 5.5. then i tried installing from yum , i got the same error.

Did you try to locate Collectd/Unixsock.pm on your system? In order for
perl to find it, it needs to be found in any of the paths listed in @INC
(see the error message). If that's not the case, a work-around would be
to copy or symlink it to collection3/lib/.

See the Perl documentation for more details about the module search


Sebastian "tokkee" Harl +++ GnuPG-ID: 0x8501C7FC +++ http://tokkee.org/

Those who would give up Essential Liberty to purchase a little Temporary
Safety, deserve neither Liberty nor Safety.         -- Benjamin Franklin

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: Digital signature
Url : http://mailman.verplant.org/pipermail/collectd/attachments/20100823/245219ab/attachment.pgp 

More information about the collectd mailing list