[collectd] libiptc build problems

Florian Forster octo at verplant.org
Thu Sep 17 17:47:46 CEST 2009

Hi Mirko,

On Thu, Sep 17, 2009 at 04:27:06PM +0200, Mirko Buffoni wrote:
> I'm trying to compile version 4.8.0 which I redownloaded again, but
> there is no such option --with-libiptc=shipped
> If I specify --with-libiptc=yes, it compiles the library and libs can
> be found under src/owniptc/.libs/

sorry about this mess :/ Linking with libiptc is a PITA thanks to the
early versions being “unofficial”. 

Unfortunately, the build system in 4.7.2 and 4.6.4 (and earlier) is
broken: When a local installation of libiptc exists, the shipped header
files will be used but the shared object will be linked against the
global library. Due to an ABI change this causes segmentation faults.

We tried to fix this issue in 4.7.3 and 4.6.5 but the solution backfired
and that's what you're experiencing right now ;)

I tried to explain why linking with libiptc is to hard in the wiki [0].
Hope that helps to clarify the problem.

I hope that the problems are all solved in the Git repository. It'd be
awesome you you could check out either the “master”, “collectd-4.8” or
“collectd-4.7” branch and give it a try – the changes are the same in
all three branches.


[0] <http://collectd.org/wiki/index.php/Plugin:IPTables#Shipped_libiptc>
Florian octo Forster
Hacker in training
GnuPG: 0x91523C3D
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://mailman.verplant.org/pipermail/collectd/attachments/20090917/2fbcce4d/attachment.pgp 

More information about the collectd mailing list