[collectd] collectd 4.6.1 make fails on FreeBSD

Boogie boogie at deck13.ru
Mon Feb 23 23:37:32 CET 2009

I've tried to build collectd 4.6.1 on my FreeBSD box today, but it failed:

client.c: In function 'lcc_getval':
client.c:681: error: 'EILSEQ' undeclared (first use in this function)
client.c:681: error: (Each undeclared identifier is reported only once
client.c:681: error: for each function it appears in.)
cc1: warnings being treated as errors
client.c: In function 'lcc_putval':
client.c:752: warning: implicit declaration of function 'isnanf'
client.c:752: warning: incompatible implicit declaration of built-in 
function 'isnanf'
client.c: In function 'lcc_listval':
client.c:888: error: 'EILSEQ' undeclared (first use in this function)

I've tried to configure it without almost any plugins, but nothing 
changed. Ok, I thought, maybe it's just my bad karma, or something? And 
ran gmake on another FreeBSD box I have. Same result. For the purity of 
the experiment I've tried to build it on Slackware box I have access to, 
and it was successful. So, here I am, asking for help :) Has anybody 
(successfully or not) compiled 4.6.1 on FreeBSD?

[mailto:boogie at deck13.ru]

More information about the collectd mailing list