[collectd] collection.cgi

Florian Forster octo at verplant.org
Sat Nov 10 11:55:28 CET 2007

Hi Chrs,

On Sat, Nov 10, 2007 at 12:45:37AM +0100, KW 1C wrote:
> If I run it under the root account from a shell I see the right output
> however running under the nobody account (via the web server or any
> other account) I get no output.

this sounds a lot like a permission proglem. Can non-root users read the
data directory? Is the configuration file of collection.cgi (usually
/etc/collection.conf) readable by the webserver user?

>         <select name="host" multiple="multiple" size="10">
>           <option value="cpu-0">cpu-0</option>
>           <option value="df">df</option>

Listed in the `host' list are the plugins. You have probably configured
something like
 datadir: "/var/lib/collectd/rrd/myhost/"
when it should have been
 datadir: "/var/lib/collectd/rrd/"

> I tried moving the data files to the webroot and many other places but
> always with the same result What do I miss....????

Try to play webserver yourself and see what fails:
 $ sudo -u webserver-user find /var/lib/collectd/rrd/ -name '*.rrd'
 $ sudo -u webserver-user cat /etc/collection.conf
(of course you need to substitute `webserver-user' with the actual
username your webserver runs as, e. g. `www-data' is Debian's default).

Florian octo Forster
Hacker in training
GnuPG: 0x91523C3D
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://mailman.verplant.org/pipermail/collectd/attachments/20071110/b35c78a9/attachment-0001.pgp 

More information about the collectd mailing list