[collectd] libperl and DEBUG macro (was: rc8 is not working)

Florian Forster octo at verplant.org
Sat May 12 08:25:28 CEST 2007


Hi,

On Wed, May 09, 2007 at 09:37:34PM +0200, Sebastian Harl wrote:
> Flo, as DEBUG is a very generic name that might be used in a variety
> of different locations it might make sense to rename the collectd
> macros to something more specific. One the other hand, it should not
> get too long, so something like C_DEBUG (think COLLECTD_DEBUG) or
> LOG_DEBUG, etc. would imho be a good compromise. What do you think?

I think this sucks. Generic names should be reserved to applications and
should not be used in libraries :/

I'd prefer to stick with the `DEBUG' macro and code around this issue
with something like this:
-- 8< --
 #include "plugin.h"
 #define LOG_DEBUG DEBUG
 #undef DEBUG
 #include <perl.h>
-- >8 --
or
-- 8< --
 #include <perl.h>
 #ifdef DEBUG
 # undef DEBUG
 #endif
 #include "plugin.h"
-- >8 --

> > btw, i have over 400 servers here with different linux distros, so
> > you can be sure, collectd will be well tested.

Sweet :) Sergiusz, maybe you could give us some performance
information..? I'd be very interested in how well collectd scales up.

Regards,
-octo
-- 
Florian octo Forster
Hacker in training
GnuPG: 0x91523C3D
http://verplant.org/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://mailman.verplant.org/pipermail/collectd/attachments/20070512/b7a81a7b/attachment.pgp 


More information about the collectd mailing list