[collectd] Problems with 'traffic' plugin

Sune Marcher sm at flork.dk
Tue May 2 12:30:28 CEST 2006

Hello Florian,

It's pretty weird. There's no messages in the syslog from collectd at
all (which should of course be a good sign, had 'traffic' worked).

I added a "syslog("it worked")" after the getifaddrs() null-check -
which *does* pop up in the syslog. Then I added a syslog() to the for
loop, and from that it seems like all the returned interfaces'
ifa_data member is NULL - weird!

Is there some kernel options I need enabled for getifaddrs to work?

> Could you send some more information about your system? You
> Kernel(-version), libc version, gcc version, ...?

Slackware 9.0.0, Kernel 2.4.30, gcc version 3.2.2 - and whatever libc
slack came with (libc-2.3.1.so?)

> No, sorry, I don't know.. But I wouldn't be surprised if `getifaddrs(3)'
> returned interface aliases as well..

Perhaps - if it worked :)
A discouraging thing, though, is that 'ifconfig' doesn't show traffic
for the alias interfaces, only for the main physical interface :/

> The various rrdtool-manpages are pretty good, though somewhat academic..
> A little easier to understand could be the `rrdtutorial' by Alex van den
> Bogaerdt: <http://oss.oetiker.ch/rrdtool/tut/rrdtutorial.en.html>. IIrc
> the RRDTool homepage has some links to more documentation..

Thanks, I'll browse around.

Best regards,
 Sune Marcher <sm at flork.dk>

More information about the collectd mailing list