[collectd] Multicast

Jeff Haney collectd@verplant.org
Fri, 7 Oct 2005 06:45:02 -0400

I would appreciate any help anyone could give me getting the multicast 
option to work.  It's not working and I'm not getting any feedback from the 
daemon as to why.  Right now I'm testing collectd on one server, one client 
machine.  Collectd has been started on the client with "-c", on the server 
with "-s".  The server is generating it's own stats in /var/lib/collectd, 
the client is not, presumably because it is in "send" mode however the 
server is not receiving anything.  ifconfig shows "UP BROADCAST RUNNING 
MULTICAST  MTU:1500  Metric:1" on the interfaces for both machines.  Doing 
an "ip route add dev eth0" and pinging gets a response 
from quite a few servers on the network so multicast appears to be working. 
Doing "ip route add dev eth0" gives me a error, not sure why, 
and I get no response when trying to ping  I don't know much 
about multicast but did a little reading before trying to configure collectd 
for sender and listener.  Also tried creating a subdirectory under 
/var/lib/collectd on the server machine with the hostname of the client 
machine (tried fully qualified and not qualified) but that didn't have any 
affect.  Thanks in advance for any help anyone can offer.