[collectd-changes] collectd, the system statistics collection daemon: Changes to 'master'

Florian Forster octo at verplant.org
Fri Aug 29 07:03:51 CEST 2014


 AUTHORS                      |    4 ++
 configure.ac                 |   14 ++++--
 contrib/redhat/collectd.spec |    3 +-
 src/Makefile.am              |    5 ++
 src/collectd.conf.in         |    1 +
 src/collectd.conf.pod        |    6 +++
 src/write_riemann.c          |   24 +++++++--
 src/zfs_arc.c                |  114 ++++++++++++++++++++++++++++++++++++++++--
 8 files changed, 156 insertions(+), 15 deletions(-)

New commits:
commit 68108d7b5688f4db5257a90437e50428a88d594a
Merge: bca0f0a 5e6230c
Author: Marc Fournier <marc.fournier at camptocamp.com>
Date:   Fri Aug 22 23:22:34 2014 +0200

    Merge branch 'feature/ZOL'
    
    Conflicts:
    	configure.ac

commit bca0f0af973fcd4b34e3cf6072e193ac9dbc65fc
Merge: 39771ec b87c575
Author: Florian Forster <octo at collectd.org>
Date:   Fri Aug 22 07:23:28 2014 +0200

    Merge remote-tracking branch 'github/pr/706'
    
    Conflicts:
    	src/write_riemann.c

commit b87c57591e40b3d9cd86c0a382818acc78558d96
Author: Moshe Zada <moshe at forter.com>
Date:   Thu Aug 21 15:23:27 2014 +0300

    Small naming conventions fixes, let the user to choose its delimiter

commit df328881b5cde03b22aa053067c58117e8809663
Author: Moshe Zada <moshe at forter.com>
Date:   Thu Aug 21 09:06:31 2014 +0300

    s/appended/used/ according to PR 706

commit c336dd75b932a7c269dff2c2dbe415026c9678da
Author: ~/.gitconfig <moshe at forter.com>
Date:   Sun Aug 17 17:19:55 2014 +0300

    rename prefix variable to eventServicePrefix

commit 5df6d83034a69e6a97cbc135c7a60301d1d47d92
Author: ~/.gitconfig <moshe at forter.com>
Date:   Sun Aug 17 17:16:34 2014 +0300

    check the status of cf_util_get_string

commit 820f3b25c7ead76617cc843cfe2e2c364b226f82
Author: ~/.gitconfig <moshe at forter.com>
Date:   Sun Aug 17 11:45:19 2014 +0300

    ignore EventServicePrefix when its empty ("")

commit f3cff943ff2df59718451247a10d3fd5d0505b45
Author: ~/.gitconfig <moshe at forter.com>
Date:   Sun Aug 17 10:01:44 2014 +0300

    Add documentation about the plugin in the pod file

commit 21dc424258a708f6e1b16e25abdd562ddd19a97a
Author: ~/.gitconfig <moshe at forter.com>
Date:   Fri Aug 15 21:46:02 2014 +0300

    Fix indentation, change Prefix to EventServicePrefix

commit 0f91e061e4e3cea3bd42a14fece8f9654c7ca443
Author: ~/.gitconfig <moshe at forter.com>
Date:   Thu Aug 14 17:37:10 2014 +0300

    handle prefix=null

commit e13fe5ecd3ca0a487f1af33c10f92bc37bb17aa3
Author: ~/.gitconfig <moshe at forter.com>
Date:   Thu Aug 14 16:50:24 2014 +0300

    refactor prefix feature - cast directly to service_buffer

commit 96708a7981cdd5ea092d5b42f19ba3784cc9d8c7
Author: ~/.gitconfig <moshe at forter.com>
Date:   Wed Aug 13 15:06:43 2014 +0300

    add the prefix feature to the src

commit 5e6230c1597ba02a4fb815d2bd553e64028675f5
Author: Marc Fournier <marc.fournier at camptocamp.com>
Date:   Mon Jul 28 15:12:42 2014 +0200

    zfs_arc: bugfix: increment array index
    
    also avoid recycling the previous iterator, for the sake of better code
    understanding.

commit 3aeea86c1adde5caa7bf18f5054b5acbf359546e
Author: Marc Fournier <marc.fournier at camptocamp.com>
Date:   Mon Jul 28 15:04:24 2014 +0200

    zfs_arc: pass reference in llist instead of value
    
    This avoids using a void pointer, which size depends on the
    architecture.
    
    Thanks to @dothebart for pointing this out!

commit 545c137af7e355f37d41beae594ae4e812a33264
Author: Marc Fournier <marc.fournier at camptocamp.com>
Date:   Wed Jul 23 23:41:10 2014 +0200

    rpm specfile: enable zfs_arc by default

commit 9f594db8977f32dd2683ceecd1d47281abc99adf
Author: Marc Fournier <marc.fournier at camptocamp.com>
Date:   Wed Jul 23 23:39:20 2014 +0200

    zfs_arc: copyright & attribution

commit 7f2441d986e8e586f3e8441095d49570bf0b7990
Author: Marc Fournier <marc.fournier at camptocamp.com>
Date:   Wed Jul 23 23:38:19 2014 +0200

    zfs_arc: style consistency

commit 534ebbeacf7905d7df58fd9d2e51563d1840986b
Author: Marc Fournier <marc.fournier at camptocamp.com>
Date:   Wed Jul 23 23:12:11 2014 +0200

    zfs_arc: pass reference in llist instead of value
    
    This allows the actual values from getting stored, not the pointer
    addresses.

commit 3e0942fc2d97a3028b9244fde6605c9ba68224fe
Author: Wilfried Goesgens <dothebart at citadel.org>
Date:   Wed Jul 23 14:15:43 2014 +0200

    zfs_arc: support for zfsonlinux
    
    fix alocation schemes so the plugin actually works
     - specify type llist_t kstat_t, so we can easily pass in our parsed data
     - read the file into one chunk of memory so we have the values available
     - count the number of lines to allocate the long pointer array
     - parse the buffer line by line.

commit 521df2eab8db4c5d370310b9739fbdb6a3e66557
Author: Marc Fournier <marc.fournier at camptocamp.com>
Date:   Fri Feb 7 14:51:31 2014 +0100

    zfs_arc: support for zfsonlinux
    
    The plugin is structured for Solaris & FreeBSD's get_kstat_value() &
    sysctlbyname() functions, which return a single metric based on its
    name. ZFS-on-Linux publishes all the stats together in a file in /proc,
    which is quite a different approach.
    So the idea is to simulate the Solaris/FreeBSD way of doing by using
    llist_search() on a linked-list containing all the key/values from the
    /proc file. This prevents having to parse it over and over again for
    each metric we request.

commit 15e2832f8f3efffa195b1185b4fdc2ddb64bde79
Author: Marc Fournier <marc.fournier at camptocamp.com>
Date:   Mon Feb 3 01:08:00 2014 +0100

    auto{conf,make} kernel-related macros consistency
    
     - add AC_DEFINEs for 2 kernels which were missing them.
     - declare AM_CONDITIONALs for all kernels we know about + move
       declaration at a more sensible location in the file.




More information about the collectd-changes mailing list