[collectd-changes] collectd, the system statistics collection daemon: Changes to 'master'
Florian Forster
octo at verplant.org
Sat Nov 6 09:40:08 CET 2010
configure.in | 8 ++
src/Makefile.am | 9 ++
src/lpar.c | 273 +++++++++++++++++++++++++++++++++++++++++++++++++++++++
src/types.db | 1 +
4 files changed, 291 insertions(+), 0 deletions(-)
New commits:
commit fbb822b876e877c69be066ceca693769d4a9618a
Merge: 626041ce6fa004ce49c183f35147f762a63cf302 584b130e51fc0e8214c8b4499b404e8728356fd9
Author: Florian Forster <octo at leeloo.lan.home.verplant.org>
Date: Sat Nov 6 09:40:05 2010 +0100
Merge branch 'ar/lpar'
commit 584b130e51fc0e8214c8b4499b404e8728356fd9
Author: Aurelien Reynaud <collectd at wattapower.net>
Date: Thu Oct 14 22:09:29 2010 +0200
lpar plugin: rename NS_TO_TICKS() macro to CLOCKTICKS_TO_TICKS()
Signed-off-by: Aurelien Reynaud <collectd at wattapower.net>
Signed-off-by: Florian Forster <octo at huhu.verplant.org>
commit 98290217039439918c6271a187a2451f16a09b60
Author: Aurelien Reynaud <collectd at wattapower.net>
Date: Thu Oct 14 22:09:28 2010 +0200
lpar plugin: update commen t regarding poll_idle vs pool_busy
Signed-off-by: Aurelien Reynaud <collectd at wattapower.net>
Signed-off-by: Florian Forster <octo at huhu.verplant.org>
commit 74dbb25f6756bceced459c3fefbdbc678739004a
Author: Aurelien Reynaud <collectd at wattapower.net>
Date: Thu Oct 14 22:09:27 2010 +0200
lpar plugin: check for donation support in libperfstat
Signed-off-by: Aurelien Reynaud <collectd at wattapower.net>
Signed-off-by: Florian Forster <octo at huhu.verplant.org>
commit 89578615b8f268f2150f786567eb433b6fcbc7e4
Author: Florian Forster <octo at huhu.verplant.org>
Date: Wed Oct 6 14:32:56 2010 +0200
lpar plugin: Calculate "pool busy" from "pool idle", not the other way around.
commit ddeeba4c8179448e3045403823f327254c781257
Author: Florian Forster <octo at huhu.verplant.org>
Date: Sun Sep 12 08:21:08 2010 +0200
lpar plugin: Use a global "perfstat_partition_total_t" struct.
commit 391525575021816a6b90a771af704d5f16184538
Author: Florian Forster <octo at huhu.verplant.org>
Date: Sun Sep 12 08:07:38 2010 +0200
lpar plugin: Account "idle" pool time rather than "max".
commit 8341769294c500d8b0aa8e689aa0cfc72a63a09b
Author: Florian Forster <octo at leeloo.lan.home.verplant.org>
Date: Sat Sep 11 11:24:14 2010 +0200
lpar plugin: Explain donations a bit more.
commit 3d1f7d99659e43efae646f18602c5f0360f255a8
Author: Florian Forster <octo at leeloo.lan.home.verplant.org>
Date: Sat Sep 11 11:18:47 2010 +0200
lpar plugin: Rename the "system" metric (from "sys").
commit 7134cf10f759b177fa0410dcc9caeaaf09dd0336
Author: Florian Forster <octo at leeloo.lan.home.verplant.org>
Date: Sat Sep 11 11:04:44 2010 +0200
lpar plugin: Introduce a "NS_TO_TICKS" macro.
This makes the code easier to read, IMHO.
commit 75efef3359f6565c8833563414367b89fbeacc46
Author: Florian Forster <octo at leeloo.lan.home.verplant.org>
Date: Sat Sep 11 11:04:04 2010 +0200
lpar plugin: Move / add comments.
commit 3451d2486faf938b9e78dafcdf8c30ed375af19f
Author: Aurélien Reynaud <aurelien at wattapower.net>
Date: Thu Sep 9 22:43:16 2010 +0200
lpar plugin update
Hello,
here is a new patch against ar/lpar with the following features :
- get back to the original implementation with gauges only. A new type
"vcpu" is created (it was "lpar_pcpu" in the original)
- I tried to keep as much as possible of your changes, but some have
been reverted (the init function is back) because it was simpler for me
to port my previous code rather than adapt it to the current form. Feel
free to change them again
- the "consumed" metric might seem superfluous at first sight as it
could be calculated in the frontend in the general case. But I thought
it might come in handy when dealing with dedicated partitions, where
donated and stolen values are no easy concepts. Not everyone wants to
dig into the code and the APIs to find out what they mean and whether
they should be added to or substracted from other values...
As a side note, one of the changes you introduced was better checking
of the return status from perfstat_partition_total() using errno. This
reminded me that under AIX errno is by default unsafe to use in a
multithreaded environment (which collectd is). I posted a fix ("Fix
errno thread-safety under AIX") on Sat, 19 Jun 2010, which if I am not
mistaken has not been merged yet.
Best regards,
Aurélien Reynaud
Signed-off-by: Florian Forster <octo at huhu.verplant.org>
commit fc562e3e9264474183b430f71972cca6434691b3
Author: Florian Forster <octo at leeloo.lan.home.verplant.org>
Date: Fri Sep 3 12:48:26 2010 +0200
lpar plugin: Fix error handling of the "perfstat_partition_total" function.
According to the documentation the function returns -1 on error. The
code now assumes anything but one (the number of structures filled) as
error.
commit 51f35f06cdcae02cc5c71baab2ac6a85d155d5a0
Author: Florian Forster <octo at leeloo.lan.home.verplant.org>
Date: Fri Sep 3 12:22:25 2010 +0200
lpar plugin: Document why comsumed ticks may be larger than entitled ticks.
commit 5f1725febf9aaa48fae42058d875202882bd7147
Author: Florian Forster <octo at leeloo.lan.home.verplant.org>
Date: Fri Sep 3 11:05:37 2010 +0200
lpar plugin: Refactor reading of "shared partitions".
Especially calculating the ticks unavailable to the partition has been
improved. The "pool statistics" may need some further work.
The code has been written without an AIX machine at hand, so it's
absolutely untested and may not even compile. Sorry.
commit 609adfb86b92992c086113a8f4adbb84077165f2
Author: Florian Forster <octo at leeloo.lan.home.verplant.org>
Date: Fri Sep 3 09:39:13 2010 +0200
lpar plugin: Use booleans for the config options.
commit 3e375cba6873e0e5d47de4b16058cbd5ceb96184
Author: Aurélien Reynaud <collectd at wattapower.net>
Date: Wed Sep 1 22:28:38 2010 +0200
lpar plugin: new attempt
Hello Florian,
here is a new version of my lpar plugin. I tried to address the
shortcomings of the previous attempt:
- Minimum and maximum proc capacity are gone, being static values
- The plugin now uses the cpu type for every value, so there is no need
anymore for the lpar_cpu type
- This also means there is no need anymore to compute rates in the
plugin, so the code is IMHO much more elegant
- There is a config option "ReportBySerial", as described in my previous
email
- We now use pool_busy_time directly instead of computing it from total
and idle
The patch is against the current 4.10 branch, rather than against
ar/lpar, because it is more of a complete rewrite than just fixes. I
could provide a patch against ar/lpar however if you prefer so.
Regards,
Aurélien Reynaud
Signed-off-by: Florian Forster <octo at leeloo.lan.home.verplant.org>
commit f3feef5de90c0c926ee76c96972c4ce4b8b5c838
Author: Florian Forster <octo at huhu.verplant.org>
Date: Wed Aug 18 11:31:38 2010 +0200
lpar plugin: Use the "cpu" type for the general CPU statistics.
commit 2254a769156fd0461e2fc5e33dedf17c16c53057
Author: Aurélien Reynaud <collectd at wattapower.net>
Date: Tue Aug 10 20:37:53 2010 +0200
New plugin - lpar
Hello,
here is a patch against 4.10 adding a new plugin "lpar".
LPAR stands for Logical PARtitions, which is the virtualization solution
for IBM high-end power systems running AIX.
The standard cpu plugin shows cpu usage as a percentage of each cpu
available to the system, but in an LPAR the number of cpus and their
apparent power can vary according to the load of every LPAR sharing the
same hardware and to the policy set by the admin.
This new plugin allows to monitor real (physical) CPU usage of the
virtualized system, as well as some other metrics specific to IBM's
partitioning solution.
Regards,
Aurélien Reynaud
--
Love is like PI - natural, irrational, endless, and very important.
Signed-off-by: Florian Forster <octo at huhu.verplant.org>
More information about the collectd-changes
mailing list