[collectd-changes] collectd, the system statistics collection daemon: Changes to 'master'

Florian Forster octo at verplant.org
Mon Dec 7 11:53:10 CET 2009


 AUTHORS               |    1 +
 src/collectd.conf.pod |    6 +
 src/openvpn.c         |  623 ++++++++++++++++++++++++++++++++++++++++---------
 src/types.db          |    1 +
 4 files changed, 515 insertions(+), 116 deletions(-)

New commits:
commit a87b2b7485986ea0ea5f8ed0f20a0507ff8dc7d5
Merge: ce1ff58f29fd7f79fd2a4e2263f8e10b3fa4f5af ddb5eb9c7740dce805900afc650e29406258f689
Author: Florian Forster <octo at huhu.verplant.org>
Date:   Mon Dec 7 11:53:08 2009 +0100

    Merge branch 'mc/openvpn'

commit ddb5eb9c7740dce805900afc650e29406258f689
Author: Florian Forster <sifnfors at informatik.stud.uni-erlangen.de>
Date:   Mon Dec 7 11:50:36 2009 +0100

    openvpn plugin: Added comments and vim formatting line.

commit 424eab864a9f290d4a7638e0af03831429d48da8
Author: Florian Forster <octo at huhu.verplant.org>
Date:   Mon Dec 7 11:50:02 2009 +0100

    openvpn plugin: Remove one level of indentation in the read functions.

commit cf191cf7843ff95a1e52a4e9501a2dfdcf59c53b
Author: Florian Forster <octo at huhu.verplant.org>
Date:   Mon Dec 7 11:48:16 2009 +0100

    openvpn plugin: Rename the arguments of the submit functions.
    
    "Type" is being used for something different, don't use that argument
    name here.

commit 2e39c96677b5c40e9ee87888f361ef13c267a6b0
Author: Marco Chiappero <marco at absence.it>
Date:   Tue Dec 1 12:09:51 2009 +0100

    openvpn plugin: Implement the “ImprovedNamingSchema” config option.
    
    I'm attaching a new version that includes this config key. By default the old
    naming schema is used, while for the single mode the new naming schema is
    always used since there's no backward compatibility to be preserved. You can
    use the previous file[1] for the 5.0 branch where only the new naming schema
    will be used. A new man page text is still lacking, maybe I'll write it in the
    next days.

commit cbeef3fed84d8fd65e624888455f36ba3c848215
Author: Florian Forster <octo at leeloo.lan.home.verplant.org>
Date:   Fri Sep 25 12:14:11 2009 +0200

    collectd.conf(5): openvpn plugin: Document the "Compression" option.

commit 52e5699e99e42852693541591e568b622e149e53
Author: Florian Forster <octo at leeloo.lan.home.verplant.org>
Date:   Fri Sep 25 12:11:45 2009 +0200

    AUTHORS: Update Marco's entry.

commit aca8f06eb3019d334a4c50a5d838bb3e505f33ee
Author: Florian Forster <octo at leeloo.lan.home.verplant.org>
Date:   Fri Sep 25 12:10:10 2009 +0200

    openvpn plugin: single_read: Remove one level of indentation.

commit 3d72cbbc967f46546379ec10cba326c2d1307cec
Author: Florian Forster <octo at leeloo.lan.home.verplant.org>
Date:   Fri Sep 25 11:58:50 2009 +0200

    openvpn plugin: Use tabs for indentation only.
    
    Whitespace-only commit.

commit 52d020c880a5cf741d00ea3675966e7e0e9d2f36
Author: Florian Forster <octo at leeloo.lan.home.verplant.org>
Date:   Fri Sep 25 11:49:45 2009 +0200

    openvpn plugin: multi1_read: Replace a hard to read for-loop with a while-loop.

commit dbf9711493bf34019c1bfd359a80c1b94d78e5bd
Author: Florian Forster <octo at leeloo.lan.home.verplant.org>
Date:   Fri Sep 25 11:39:02 2009 +0200

    openvpn plugin: Improve “version_detect”.
    
    Remove “fscanf” with used the insecure “%s” format string. Pass the
    filename rather than the file handle to the function.

commit fdfe18390b435b72ed9fead64c53e1d7f5b873c7
Author: Florian Forster <octo at leeloo.lan.home.verplant.org>
Date:   Fri Sep 25 09:28:11 2009 +0200

    openvpn plugin: Remove trailing whitespace.

commit 845cac1eaa492eb59d86d52a2367a2c22198f2b4
Author: Florian Forster <octo at leeloo.lan.home.verplant.org>
Date:   Fri Sep 25 09:27:50 2009 +0200

    openvpn plugin: Don't use negated config options.
    
    “NoCompression” → “Compression”.

commit 4fa49f23569090363a8affcefe18b863cc486b29
Author: Marco Chiappero <marco at absence.it>
Date:   Fri Sep 25 09:20:56 2009 +0200

    openvpn plugin: Add forgotten frees.
    Florian Forster ha scritto:
    > Hi Marco,
    
    Hi Florian,
    
    > I'm too tired to have a look at this now, I hope to have some time in
    > the next few days. I'll come back to you asap.
    
    That's fine :)
    But sorry, I forgot to recheck a small part of the code after adding and
    moving some stuff around, please apply this patch too.
    
    Regards,
    Marco

commit 596abb464fcbf1eced599019cd107d28917bdd3f
Author: Marco Chiappero <marco at absence.it>
Date:   Fri Sep 25 09:18:02 2009 +0200

    openvpn plugin: Add support for more versions of the “status file” (and more).
    
    Hi all,
    
    I have some news regarding the Openvpn plugin.
    I recently upgraded to 4.7.2 and enabled the new (to me) openvpn plugin,
    but unfortunately it didn't work and I couldn't understand why. So had a
    look at the code and applied some changes. Here a list of things
    added:
    
    - support for multiple vpn/status files
    - support for single endpoint status file and for multicontext version
    1,3 (currently every status file type is supported)
    - status file type auto-detection
    - collection of overhead and compression stats for single mode status files
    - "NoCompression" option to disable compression statistics collection
    - new file naming schema correcting the previous wrong one
    - debug and error output
    
    The plugin has already been tested with my own openvpn setup and many
    different files found on the net, but two major aspects have to be taken
    into consideration. The first one is the new overhead collection and the
    change in the compression statistics (now data is stored as they are
    [1]). However, due to a bug in the previous code, no compression
    collection was working and so the new one is not going to brake backward
    compatibility. Unfortunately backward compatibility is broken by the
    new naming schema, more collectd compliant (and necessary with multiple
    conf/status files support). So plugin_istance is now the status file
    name (or the status entry number), while the plugin_type is now the
    hostname when in multicontext mode or the traffic and overhead when in
    single.
    About the plugin_instance value, I started using numbers like the cpu
    plugin does, but I prefer to use the self explanatory file name, helping
    in finding the right vpn and avoiding to mess things up when adding a
    new status file. The downside is that filenames have to be unique (man
    pages should mention this [2]), therefore I added a check. Nonetheless I
    think it's very unlikely to happen, it is quite rare to find many vpn on
    the same system and it's really hard to have the same log filename
    stored in different dirs rather than the opposite; usually to different
    tunnels should already correspond different status log name.
    However, Florian, feel free to choose the other method if you prefer, I
    can send you a patch to revert to the number based schema.
    Hope you like the code.
    
    Regards,
    Marco
    
    [1] This allows to retrieve multiple informations, not just the pure
    compression ratio. For example we can now calculate the pure compression
    ratio, the global compression level, the byte saved (eg. for a
    overhead vs. saved bytes graph) and so on.
    
    [2] Man pages should be updated as well, but I haven't written anything yet.




More information about the collectd-changes mailing list