[collectd-changes] collectd, the system statistics collection daemon: Changes to 'master'

Florian Forster octo at verplant.org
Wed Apr 23 15:40:29 CEST 2008


 src/apache.c           |   19 +++-----
 src/apcups.c           |    8 ++--
 src/apple_sensors.c    |   13 +++---
 src/ascent.c           |    7 ++-
 src/battery.c          |   13 +++---
 src/collectd-perl.pod  |   11 ++++-
 src/collectd.c         |    6 +--
 src/common.c           |   57 +++++++++++++------------
 src/common.h           |    1 +
 src/configfile.c       |   11 ++---
 src/cpu.c              |    8 ++--
 src/cpufreq.c          |    9 ++--
 src/csv.c              |   33 +++++++++-----
 src/df.c               |    9 ++--
 src/disk.c             |    8 ++-
 src/dns.c              |    8 ++-
 src/email.c            |    8 ++--
 src/entropy.c          |    3 +-
 src/exec.c             |   12 ++---
 src/hddtemp.c          |   12 +++---
 src/interface.c        |    5 +-
 src/ipmi.c             |    3 +-
 src/iptables.c         |   23 +++++-----
 src/ipvs.c             |   20 +++++---
 src/irq.c              |    5 +-
 src/libvirt.c          |   21 +++++----
 src/load.c             |    3 +-
 src/logfile.c          |    4 +-
 src/mbmon.c            |    5 +-
 src/memcached.c        |   37 ++++++----------
 src/memory.c           |    6 +-
 src/multimeter.c       |    3 +-
 src/mysql.c            |   14 ++++--
 src/netlink.c          |   23 +++++-----
 src/network.c          |   24 +++++------
 src/nfs.c              |   13 +++---
 src/nginx.c            |   11 ++---
 src/ntpd.c             |   14 +++---
 src/nut.c              |   13 ++---
 src/perl.c             |  111 +++++++++++++++++++++++++----------------------
 src/ping.c             |    5 +-
 src/plugin.c           |   28 +++++++++---
 src/plugin.h           |    8 ++--
 src/powerdns.c         |    9 ++--
 src/processes.c        |   27 ++++++-----
 src/rrdtool.c          |   51 +++++++++------------
 src/sensors.c          |   32 +++++---------
 src/serial.c           |    5 +-
 src/snmp.c             |   39 +++++++---------
 src/swap.c             |    5 +-
 src/tape.c             |    5 +-
 src/tcpconns.c         |   17 +++----
 src/teamspeak2.c       |   18 ++++---
 src/types_list.c       |    6 +--
 src/unixsock.c         |    4 +-
 src/users.c            |    3 +-
 src/utils_cache.c      |    6 +--
 src/utils_cmd_putval.c |    6 +-
 src/utils_dns.c        |    9 ++--
 src/utils_ignorelist.c |    2 +-
 src/utils_mount.c      |    6 +--
 src/utils_tail_match.c |    3 +-
 src/utils_threshold.c  |   82 +++++++++++++++---------------------
 src/uuid.c             |    3 +-
 src/vmem.c             |    3 +-
 src/vserver.c          |   34 +++++++++------
 src/wireless.c         |    5 +-
 src/xmms.c             |    3 +-
 68 files changed, 526 insertions(+), 512 deletions(-)

New commits:
commit 5f9ec13b946733ff4e1edf2d8e3b7a22311dd894
Author: Sebastian Harl <sh at tokkee.org>
Date:   Sun Apr 20 23:20:45 2008 +0200

    Unified string handling.
    
    sstrncpy() and the newly added function ssnprintf() are now used all over
    the place to make sure strings are null terminated. This removes quite
    some duplicate code that was found all over the place and thus fairly
    increases overall readability of the code. Also sizeof() is used instead
    of hard-coded constants where appropriate to determine the available
    space.
    
    Signed-off-by: Sebastian Harl <sh at tokkee.org>
    Signed-off-by: Florian Forster <octo at huhu.verplant.org>

commit 2354eda94fa44c8bcb8e39b24b117e7937110224
Author: Sebastian Harl <sh at tokkee.org>
Date:   Sun Apr 20 23:19:28 2008 +0200

    Added "type" to the value_list_t struct.
    
    This way, the complete tuple (host, plugin, plugin instance, type, type
    instance) is stored in a single data-type which is more straight forward
    and allows a more flexible use of that data-type. As a consequence, there
    is no longer a need to explicitly pass the type to some functions, most
    notably plugin_dispatch_values(), which have been updated in that respect.
    
    The "perl" plugin has also been updated to reflect this change. For
    backwards compatibility, plugin_dispatch_values() still accepts a second
    argument - however, a warning will be submitted to the daemon in that
    case.
    
    Signed-off-by: Sebastian Harl <sh at tokkee.org>
    Signed-off-by: Florian Forster <octo at huhu.verplant.org>




More information about the collectd-changes mailing list