[collectd-changes] collectd, the system statistics collection daemon: Changes to 'collectd-4.3'

Florian Forster octo at verplant.org
Tue Apr 1 15:07:21 CEST 2008


 configure.in           |   31 ++++---
 contrib/collection.cgi |  222 ++++++++++++++++++++++++++++++++++++++----------
 src/apache.c           |   41 ++++++---
 src/collectd.h         |   18 ++++
 src/common.c           |    5 +-
 src/hddtemp.c          |   39 +++++----
 src/plugin.c           |   27 +++++-
 src/unixsock.c         |    1 -
 8 files changed, 286 insertions(+), 98 deletions(-)

New commits:
commit 4fb5d4b471e3f6a24d7cd36272e48e57bcb2c68f
Merge: a962cc65ed7e9fd1c26ee5f4172d3d0b82c8ec5f cc198156a5fbf657481c29329982adac3878bee4
Author: Florian Forster <octo at noris.net>
Date:   Tue Apr 1 15:05:45 2008 +0200

    Merge branch 'collectd-4.2' into collectd-4.3
    
    Conflicts:
    
    	configure.in
    	src/plugin.c

commit cc198156a5fbf657481c29329982adac3878bee4
Author: Sebastian Harl <sh at tokkee.org>
Date:   Mon Mar 31 11:31:38 2008 +0200

    unixsock plugin: Do not unregister a write-callback in us_shutdown().
    
    The unixsock plugin no longer registers a write-callback. Basically,
    unregistering a non-existent callback does not do any harm, However, if no
    write-callback has been registered at all, the appropriate linked list has
    never been created and the process will segfault when trying to access it.
    
    Signed-off-by: Sebastian Harl <sh at tokkee.org>
    Signed-off-by: Florian Forster <octo at huhu.verplant.org>

commit 06c09feedb03c7167168a0caacd9afdd5fe4e985
Author: Florian Forster <octo at noris.net>
Date:   Tue Apr 1 14:11:35 2008 +0200

    configure.in: Set CPPFLAGS when checking headers.
    
    When checking for <upsclient.h> (and the headers of a few other libraries) the
    library specific CFLAGS were added to the global CFLAGS variable. This variable
    is used when checking for ``header usability'', but not when checking for
    ``header presence'' for some reason.
    
    This commit uses the global CPPFLAGS variable instead, which is used in both
    checks. Libraries that benefit from this commit are:
    - libcurl,
    - libmysql(client),
    - libnetsnmp,
    - libupsclient.
    
    Resolves #6

commit 5c3efb12ed19f99017b8b13943d4a983de040050
Author: Florian Forster <octo at noris.net>
Date:   Tue Apr 1 10:40:39 2008 +0200

    apache plugin: Increase the size of the read-buffer dynamically.
    
    Why guess the size if you can just adapt to whatever comes in? The memory isn't
    freed ever, though.

commit dae0b188243d483bfac124f1b4c070830504ab75
Author: Florian Forster <octo at huhu.verplant.org>
Date:   Mon Mar 31 17:03:56 2008 +0200

    src/plugin.c: plugin_dispatch_values: Improve the error messages.
    
    If no write plugin was loaded or no DS was defined, the
    `plugin_dispatch_values' used to fail silently. This is of course not good, so
    this commit introduces error messages for this case, so that users can see why
    their setup is not working properly.
    
    Also, the ``no such DS type'' message was promoted from DEBUG to INFO.

commit c42a2315b0b8fa86264c8202f661bef8e683ed20
Author: Florian Forster <octo at huhu.verplant.org>
Date:   Mon Mar 31 15:51:13 2008 +0200

    src/common.c: Make really sure BYTE_ORDER and BIG_ENDIAN are defined.
    
    If both, BYTE_ORDER and BIG_ENDIAN, are undefined, the statement
      #if BYTE_ORDER == BIG_ENDIAN
    will be evaluated to `true', which may cause `ntohll' and `htonll' to behave
    weird.

commit 20d7c9833c8c11d4a1039b5bf0eab4ad8e8f5281
Author: Sebastian Harl <sh at tokkee.org>
Date:   Mon Mar 31 10:46:42 2008 +0200

    plugin.c: Tell the user if a plugin could not be found.
    
    Up to now this error was silently ignored, letting the user believe that
    everything went fine.
    
    Signed-off-by: Sebastian Harl <sh at tokkee.org>
    Signed-off-by: Florian Forster <octo at huhu.verplant.org>

commit 130d20f6a99beb99b5370ed108732a15a4ce6440
Author: Sebastian Harl <sh at tokkee.org>
Date:   Sun Mar 30 20:00:45 2008 +0200

    collection.cgi: Make sure to pass valid variable names to rrdgraph.
    
    Variable names used with DEF, VDEF, etc. must be made up of the
    characters "A-Z, a-z, 0-9, -, _". In meta_graph_generic_stack() variable
    names have been generated from the instance name which may, however,
    contain illegal characters. Now, all illegal characters will be replaced
    with "_" and a number will be prepended to the variable name to make
    sure the name is still unique.
    
    Thanks to Joerg Jaspert for pointing this out and helpful debugging
    information.
    
    Signed-off-by: Sebastian Harl <sh at tokkee.org>
    Signed-off-by: Florian Forster <octo at huhu.verplant.org>

commit c3ad119fdb1db54b7e9d4f63f6218b1392c6f66f
Author: Florian Forster <octo at huhu.verplant.org>
Date:   Mon Mar 31 08:29:25 2008 +0200

    hddtemp plugin: Prefix all messages with "hddtemp plugin:".

commit 2760cc10311aac2e86da335dcb982eaf2db6bff3
Author: Sebastian Harl <sh at tokkee.org>
Date:   Sun Mar 30 17:25:16 2008 +0200

    collection.cgi: Added "meta graph" for "dns_qtype" and "dns_rcode".
    
    This will merge all query types and return codes into a single graph each.
    
    get_n_colors() has been taken from the version 3 script to get the colors for
    the graphs. get_random_color() imho is not suitable for that purpose as it can
    return colors that are hardly different - which would result in graphs that
    are hard to read. get_n_colors() now returns a hash-ref suitable to be passed
    to meta_graph_generic_stack().
    
    Signed-off-by: Sebastian Harl <sh at tokkee.org>
    Signed-off-by: Florian Forster <octo at huhu.verplant.org>

commit 915950cfc280a2fdaac92f839bf5fa66db96a433
Author: Sebastian Harl <sh at tokkee.org>
Date:   Sun Mar 30 19:35:14 2008 +0200

    collection.cgi: Added support for "wireless" values.
    
    Signed-off-by: Sebastian Harl <sh at tokkee.org>
    Signed-off-by: Florian Forster <octo at huhu.verplant.org>

commit dec2bb278a1d0aa2ec66dbe1d428861dfb46517d
Author: Sebastian Harl <sh at tokkee.org>
Date:   Sun Mar 30 15:45:04 2008 +0200

    collection.cgi: Updated "dns" types to version 4.x.
    
    Signed-off-by: Sebastian Harl <sh at tokkee.org>
    Signed-off-by: Florian Forster <octo at huhu.verplant.org>




More information about the collectd-changes mailing list